Binary Clock - Part 2s

|
| Comments (0)
I started building a binary clock (nearly a year ago). I had some surplus 7490 and 838 decade counters. These are TTL I believe and seem to have no problem driving LEDs through 150ohm resistors. I have a divide by 60 circuit that takes the 60Hz AC and produces a 1Hz clock. This feeds another 838 which is connected to a 7447 that is driving a single 7-segment LED. My last 7490 is in place to drive the 4 LEDs that will display the 0-9 minutes.

I ran out of parts :-( Here's how far I got:


binary_clock_progress.JPG Since then I received a bunch of 74C90 - CMOS variety chips. I cannot seem to get these to play nicely. I have discovered that CMOS inputs require pull up resistors, and now I am hearing that they cannot (or should not) be used to drive LEDs directly as the current is too much for them. Hmmm.. Would like to keep the part count down if I can.

Anyone willing to trade 74C90's for TTL 7490s??

I'm trying to have 2 x 74C90s count 0-59 (in binary). I have a clock line coming off my circuit board to the prototype board. I can get one 74C90N to count 0-9, however, the second 74C90N does not want to count to 5 consistently. If it does anything, it counts 0,1,2,3,4,5,4,5,4,5,4,5.....

It appears that the QC bit is turning off then back on very quickly during the reset because if I use the QC bit to drive the first 74C90, that one counts even though QC looks like it stays high.

This is my prototype mess:


74C90N_Prototypes.JPG

(Hmm... just had a thought - I have some 4050 buffers - would they be more suited to driving LEDs???)

Any advice would be appreciated! Thanks!


Leave a comment